<!doctype html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta property="x-fb:admins" content="54901647,1231435431" /><meta property="fb:app_id" content="197738670272553" /><meta name="google-site-verification" content="zQbF-ExVj-Z2rOcnHh7fpvpfXpEK6k4-QR3dM1VlCVM" /><meta name="google-site-verification" content="jUP8Pn69xiG-0GgNhmSVDih125TBJMCDEVr2b5Ec-JI" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-3437640-1', 'auto');
  ga('send', 'pageview');</script> <style>.secondary-menu .new-calendar-menu-link a{background:url(/wp-content/themes/funki/custom-images/navbar/nav-events.png);background-repeat:no-repeat;background-position:center center;width:155px;height:44px}.tribe-events-schedule h2{font-weight:normal!important;font-size:1.7em}.tribe-mini-calendar-event .list-info h2{font-weight:normal!important;font-family:Verdana,Arial,sans-serif}.tribe-mini-calendar-event .list-date{padding:0!important}.tribe-events-event-meta .tribe-events-meta-group{min-width:50%}.single-tribe_events .event-filter{display:none}.tribe-events-list .tribe-events-event-image+div.tribe-events-content{float:right!important;width:60%!important}.search h1.page-title{font-size:20px}#event-button,.event-bottom-ad{display:none}.single-tribe_events #event-button,.page-id-111284 #event-button,.post-type-archive-tribe_events #event-button,.single-tribe_events .event-bottom-ad,.page-id-111284 .event-bottom-ad,.post-type-archive-tribe_events .event-bottom-ad{display:block}.page-id-111284 h1.post-title{color:#360;font-family:Verdana,Arial,sans-serif;font-size:large;text-align:left;font-weight:700}.page-id-111284 h1.post-title>img{margin-top:15px}@media screen and (min-width:768px){.mobile-only{display:none}}@media screen and (max-width:767px){.tribe-events-list .tribe-events-event-image+div.tribe-events-content{float:right!important;width:100%!important}.post-nav .prev,.post-nav .next{width:50%!important;clear:none!important}.post-nav a{font-size:100%!important}}</style><title>FAIR HAVEN: After months of complaints, post office gets a sign.</title><link rel="stylesheet" href="https://www.redbankgreen.com/wp-content/cache/min/1/cbd0d58bedd295ca9fe8ee8cd1bc7ad7.css" data-minify="1" /><meta name="description" content="FAIR HAVEN: After months of complaints by its lone clerk, the borough post office finally has an identifying sign out front."/><link rel="canonical" href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="FAIR HAVEN: After months of complaints, post office gets a sign." /><meta property="og:description" content="FAIR HAVEN: After months of complaints by its lone clerk, the borough post office finally has an identifying sign out front." /><meta property="og:url" content="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/" /><meta property="og:site_name" content="Red Bank Green" /><meta property="article:tag" content="Fair Haven" /><meta property="article:tag" content="joe shevlin" /><meta property="article:tag" content="metro commercial" /><meta property="article:tag" content="nj" /><meta property="article:tag" content="post office" /><meta property="article:tag" content="red bank" /><meta property="article:tag" content="sign" /><meta property="article:tag" content="signage" /><meta property="article:tag" content="what&#039;s going on here" /><meta property="article:section" content="Featured" /><meta property="article:published_time" content="2020-01-02T17:25:31+00:00" /><meta property="og:image" content="https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere.jpg" /><meta property="og:image:secure_url" content="https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.redbankgreen.com/#website","url":"https://www.redbankgreen.com/","name":"Red Bank Green","publisher":{"@id":"https://www.redbankgreen.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.redbankgreen.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/#webpage","url":"https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/","inLanguage":"en-US","name":"FAIR HAVEN: After months of complaints, post office gets a sign.","isPartOf":{"@id":"https://www.redbankgreen.com/#website"},"datePublished":"2020-01-02T17:25:31+00:00","dateModified":"2020-01-02T17:25:31+00:00","description":"FAIR HAVEN: After months of complaints by its lone clerk, the borough post office finally has an identifying sign out front."},{"@type":"Article","@id":"https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/#article","isPartOf":{"@id":"https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/#webpage"},"author":{"@id":"https://www.redbankgreen.com/author/redbankgreenman/#author","name":"J ward"},"publisher":{"@id":"https://www.redbankgreen.com/#organization"},"headline":"FAIR HAVEN: SIGN OF RENEWAL?","datePublished":"2020-01-02T17:25:31+00:00","dateModified":"2020-01-02T17:25:31+00:00","commentCount":0,"mainEntityOfPage":"https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/#webpage","keywords":"Fair Haven,joe shevlin,metro commercial,nj,post office,red bank,sign,signage,what's going on here","articleSection":"FAIR HAVEN,Featured,Government,Land Use &amp; Zoning,What's Going On Here?"},{"@type":"Person","@id":"https://www.redbankgreen.com/author/redbankgreenman/#author","name":"J ward","image":{"@type":"ImageObject","@id":"https://www.redbankgreen.com/#personlogo","url":"https://secure.gravatar.com/avatar/8d5b4f8eb99dd50154ad9c0afc902373?s=96&d=mm&r=g","caption":"J ward"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//ws.sharethis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Red Bank Green &raquo; Feed" href="https://www.redbankgreen.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Red Bank Green &raquo; Comments Feed" href="https://www.redbankgreen.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Red Bank Green &raquo; iCal Feed" href="https://www.redbankgreen.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="Red Bank Green &raquo; FAIR HAVEN: SIGN OF RENEWAL? Comments Feed" href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='simple-share-buttons-adder-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=5.2.2' type='text/css' media='all' /><link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://www.redbankgreen.com/wp-content/cache/busting/1/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen-3.6.2.css' type='text/css' media='only screen and (max-width: 768px)' /><style id='woocommerce-inline-inline-css' type='text/css'>.woocommerce form .form-row .required{visibility:visible}</style><link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?family=Anton&#038;subset=latin%2Clatin-ext&#038;ver=5.2.2' type='text/css' media='all' /><link rel='stylesheet' id='wp-add-custom-css-css'  href='https://www.redbankgreen.com?display_custom_css=css&#038;ver=5.2.2' type='text/css' media='all' /> <script type='text/javascript' src='https://www.redbankgreen.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <link rel='https://api.w.org/' href='https://www.redbankgreen.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.redbankgreen.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.redbankgreen.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><meta name="generator" content="WooCommerce 3.6.2" /><link rel='shortlink' href='https://www.redbankgreen.com/?p=124744' /><link rel="alternate" type="application/json+oembed" href="https://www.redbankgreen.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.redbankgreen.com%2F2020%2F01%2Ffair-haven-spost-office-gets-new-sign%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.redbankgreen.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.redbankgreen.com%2F2020%2F01%2Ffair-haven-spost-office-gets-new-sign%2F&#038;format=xml" /><meta property="fb:app_id" content="197738670272553" /><meta name="et-api-version" content="v1"><meta name="et-api-origin" content="https://www.redbankgreen.com"><link rel="https://theeventscalendar.com/" href="https://www.redbankgreen.com/wp-json/tribe/tickets/v1/" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.redbankgreen.com"><link rel="https://theeventscalendar.com/" href="https://www.redbankgreen.com/wp-json/tribe/events/v1/" /><style type='text/css'>body{background-image:none;background-color:#000}#bgwrap{background-image:none;background-color:#000}</style><style>.selfie-help-icon{top:-26px!important}.huge-it-share-buttons h3{font-size:16px!important}</style> <!--[if lt IE 9]> <script src="https://www.redbankgreen.com/wp-content/themes/funki/js/respond.js"></script> <![endif]--> <!--[if lt IE 9]> <script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script> <![endif]--><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, minimum-scale=1, user-scalable=no"><!--[if lt IE 9]> <script src="https://s3.amazonaws.com/nwapi/nwmatcher/nwmatcher-1.2.5-min.js"></script> <script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/selectivizr/1.0.2/selectivizr-min.js"></script> <![endif]--> <noscript><style>.woocommerce-product-gallery{opacity:1!important}</style></noscript><meta name="onesignal" content="wordpress-plugin"/><style type="text/css" id="wp-custom-css">.ssba img{min-width:38px!important}</style><link rel="shortcut icon" href="/favicon.ico?2" type="image/x-icon"><link rel="icon" href="/favicon.ico?2" type="image/x-icon"></head><body class="post-template-default single single-post postid-124744 single-format-standard woocommerce-no-js tribe-no-js tribe-theme-funki skin-default webkit not-ie default_width sidebar1 no-home"><div id="fb-root"></div><div id="bgwrap"><div id="pagewrap"><div id="headerwrap"><div id="top-menu"><ul id="main-nav" class="main-nav"><li id="menu-item-83287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-83287 home-menu-link"><a href="https://www.redbankgreen.com/">Home</a></li><li id="menu-item-83269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83269 about-menu-link"><a href="https://www.redbankgreen.com/about-redbankgreen/">About</a></li><li id="menu-item-83270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83270 advertise-menu-link"><a href="https://www.redbankgreen.com/advertising-on-redbankgreen/">Advertise</a></li><li id="menu-item-84203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84203 contact-menu-link"><a href="https://www.redbankgreen.com/contact/">Contact</a></li><li id="menu-item-83272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83272 archive-menu-link"><a href="https://www.redbankgreen.com/archive/">Archive</a></li></ul><div class="header-search"><form method="get" action="https://www.redbankgreen.com/"> <input type="text" name="s" id="s"  placeholder="Search"></form></div><style>.header-weather{background:url(http://icons.wxug.com/i/c/i/.gif) no-repeat;background-position:30px top}</style><a target="_blank" href="" class="header-weather"> <span class="temp">0&deg;</span> <span class="desc"></span> </a><ul class="social-list"><li><a target="_blank" href="http://facebook.com/redbankgreen" class="facebook">Facebook</a></li><li><a target="_blank" href="http://twitter.com/redbankgreen" class="twitter">Twitter</a></li><li><a target="_blank" href="http://www.youtube.com/user/redbankgreen" class="youtube">YouTube</a></li><li><a target="_blank" href="http://www.flickr.com/photos/36177195@N07/" class="flickr">Flickr</a></li><li><a target="_blank" href="https://www.redbankgreen.com/feed/rss/" class="rss">RSS</a></li></ul><div style="clear:both;"></div></div><header id="header"><a href="http://redbankgreen.com"><img src="https://www.redbankgreen.com/wp-content/uploads/2013/09/RBG_AUTUMN-HEADER_102318-1.jpg" style="max-width: 100%; cursor: pointer;" /></a><div style="display: none;"><h1 id="site-logo"> Red Bank Green</h1></div><hgroup><h2 id="site-description" style="color: transparent; display: none;">Serving Red Bank and Greater Red Bank, NJ</h2></hgroup><div class="header-widget"><div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><style>#header .header-widget{left:5px;top:35px}</style></div></div></div></header> <span id="rbg-header-ad"> <broadstreet-zone zone-id="369" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone> </span></div><div id="body" class="clearfix"><nav id="main-nav-wrap"><div id="menu-icon" class="mobile-button"></div><div class="secondary-menu"><ul id="menu-menu-below-masthead-labor-day-launch" class="menu"><li id="menu-item-111447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111447 new-calendar-menu-link"><a href="/events">New Calendar</a></li><li id="menu-item-83297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83297 piehole-menu-link"><a href="https://www.redbankgreen.com/category/piehole/">PieHole</a></li><li id="menu-item-83298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83298 all-good-menu-link"><a href="https://www.redbankgreen.com/category/all-good/">All Good</a></li></ul></div></nav><div id="layout" class="clearfix"><div id="content" class="list-post"><article id="post-124744" class="post clearfix cat-11 cat-8298 cat-16 cat-1044 cat-19114 post-124744 type-post status-publish format-standard hentry category-fair_haven category-featured category-government category-land-use-zoning category-whats-going-on-here tag-fair-haven tag-joe-shevlin tag-metro-commercial tag-nj tag-post-office tag-red-bank tag-sign tag-signage tag-whats-going-on-here"><div class="post-content"><h1 class="post-title"><a href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/" title="FAIR HAVEN: SIGN OF RENEWAL?">FAIR HAVEN: SIGN OF RENEWAL?</a></h1></figure><p><em><strong><a href="https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere.jpg"  rel="lightbox[roadtrip]"><img class="alignnone size-full wp-image-104196" src="https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere.jpg" alt="red bank what's going on here" width="499" height="89" srcset="https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere.jpg 499w, https://www.redbankgreen.com/wp-content/uploads/2016/05/WhatsGoingOnHere-220x39.jpg 220w" sizes="(max-width: 499px) 100vw, 499px" /></a><a href="https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220.jpg"  rel="lightbox[roadtrip]"><img class="alignnone size-large wp-image-124825" src="https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-500x332.jpg" alt="fair haven post office sign" width="500" height="332" srcset="https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-500x332.jpg 500w, https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-220x146.jpg 220w, https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-768x510.jpg 768w, https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-300x199.jpg 300w, https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220-600x398.jpg 600w, https://dtuzht7vh23w6.cloudfront.net/redbankgreen/wp-content/uploads/2020/01/fair-haven-post-office-sign-010220.jpg 800w" sizes="(max-width: 500px) 100vw, 500px" /></a>It took months of complaints by a frustrated postal clerk, plus some <a href="https://www.redbankgreen.com/2019/07/red-bank-fair-haven-post-office-sign/">attention by </a></strong></em><strong><a href="https://www.redbankgreen.com/2019/07/red-bank-fair-haven-post-office-sign/">redbankgreen</a></strong><em><em><strong>, but the Fair Haven Post Office finally has an identifying sign out front.</strong></em></em></p><p><em><strong><a href="https://www.redbankgreen.com/category/whats-going-on-here/">What&#8217;s Going On Here?</a> Read on.</strong></em></p><p><span id="more-124744"></span>The absence of a sign for almost three years irritated Joe Shevlin, the sole clerk at the River Road facility. As previously reported, Shevlin was concerned that passersby might think the office was permanently closed after a 2017 <a href="https://www.redbankgreen.com/2017/04/fair-haven-acme-center-makeover-okd/">remodeling</a> of the shopping center in which it&#8217;s located.</p><p>That, in turn, might depress usage of the facility, Shevlin said. He worried that would lead the postal service not to renew its lease, which ends in May, 2022, he said.</p><div><broadstreet-zone zone-id="59215"></broadstreet-zone></div><p>On Thursday, after an exchange of internal emails in which a postal official noted that the repeated delays were &#8220;gathering unnecessary attention and reflecting poorly on our organization,&#8221; the signage was installed on the facility&#8217;s facade.</p><p>A hand-lettered cardboard sign that had been taped to the front window for months was gone.</p><broadstreet-zone zone-id="59216"></broadstreet-zone><p>Shevlin was not available for comment Thursday.</p><div class="fb-like-box" data-href="http://www.facebook.com/redbankgreen" data-width="500" data-show-faces="false" data-border-color="#ccc" data-stream="false" data-header="false"></div></p><div class="ssba-classic-2 ssba ssbp-wrap left ssbp--theme-1"><div style="text-align:left"><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/"  target="_blank" ><img src="https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/facebook.png" style="width: 38px;" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /><div title="Facebook" class="ssbp-text">Facebook</div></a><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/&amp;text=FAIR%20HAVEN%3A%20SIGN%20OF%20RENEWAL%3F%20"  target=&quot;_blank&quot; ><img src="https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/twitter.png" style="width: 38px;" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /><div title="Twitter" class="ssbp-text">Twitter</div></a></div></div><div id="themify_builder_content-124744" data-postid="124744" class="themify_builder_content themify_builder_content-124744 themify_builder themify_builder_front"></div><div class="entry-meta"> Posted on <abbr class="published" title="2020-01-02T12:25:31-0500">January 2, 2020 at 12:25 pm</abbr>, filed under <a href="https://www.redbankgreen.com/category/fair_haven/" rel="category tag">FAIR HAVEN</a>, <a href="https://www.redbankgreen.com/category/featured/" rel="category tag">Featured</a>, <a href="https://www.redbankgreen.com/category/government/" rel="category tag">Government</a>, <a href="https://www.redbankgreen.com/category/land-use-zoning/" rel="category tag">Land Use &amp; Zoning</a>, <a href="https://www.redbankgreen.com/category/whats-going-on-here/" rel="category tag">What's Going On Here?</a> and tagged <a href="https://www.redbankgreen.com/tag/fair-haven/" rel="tag">Fair Haven</a>, <a href="https://www.redbankgreen.com/tag/joe-shevlin/" rel="tag">joe shevlin</a>, <a href="https://www.redbankgreen.com/tag/metro-commercial/" rel="tag">metro commercial</a>, <a href="https://www.redbankgreen.com/tag/nj/" rel="tag">nj</a>, <a href="https://www.redbankgreen.com/tag/post-office/" rel="tag">post office</a>, <a href="https://www.redbankgreen.com/tag/red-bank/" rel="tag">red bank</a>, <a href="https://www.redbankgreen.com/tag/sign/" rel="tag">sign</a>, <a href="https://www.redbankgreen.com/tag/signage/" rel="tag">signage</a>, <a href="https://www.redbankgreen.com/tag/whats-going-on-here/" rel="tag">what's going on here</a>. Bookmark the <a href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/" title="Permalink to FAIR HAVEN: SIGN OF RENEWAL?" rel="bookmark">permalink</a>. Follow any comments here with the <a href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/feed/" title="Comments RSS to FAIR HAVEN: SIGN OF RENEWAL?" rel="alternate" type="application/rss+xml">RSS feed for this post</a>.                                                                Trackbacks are closed, but you can <a class="comment-link" href="#respond" title="Post a comment">post a comment</a>. <a href="mailto:blank?body=I thought you might be interested in FAIR HAVEN: SIGN OF RENEWAL?. You can view it at: https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign/"> Email this story.</a></div></div></article><center><span id="editorial_banner_ad"></span></center><div class="post-nav clearfix"> <span class="prev"><a href="https://www.redbankgreen.com/2020/01/red-bank-menna-offers-protocol-fix/" rel="prev">PREVIOUS: RED BANK: MENNA OFFERS PROTOCOL FIX</a></span></div><div id="comments" class="commentwrap"><a name="respond"></a><div class="fb-comments" data-href="https://www.redbankgreen.com/2020/01/fair-haven-spost-office-gets-new-sign.html" data-num-posts="20" data-width="100%"></div></div></div><aside id="sidebar"><section id="bs_zones-4" class="widget bs_zones"><div><broadstreet-zone zone-id="2079" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="bs_zones-10" class="widget bs_zones"><div><broadstreet-zone zone-id="202" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="bs_zones-14" class="widget bs_zones"><div><broadstreet-zone zone-id="47582" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="bs_zones-15" class="widget bs_zones"><div><broadstreet-zone zone-id="47584" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="bs_zones-7" class="widget bs_zones"><div><broadstreet-zone zone-id="201" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="bs_zones-18" class="widget bs_zones"><div><broadstreet-zone zone-id="200" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></section><section id="text-4" class="widget widget_text"><div class="textwidget"><iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fredbankgreen&amp;width=300&amp;height=290&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=197738670272553" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:100%; height:290px;" allowTransparency="true"></iframe></div></section><section id="tribe-events-adv-list-widget-2" class="widget tribe-events-adv-list-widget"><h4 class="widgettitle">Upcoming Events</h4><div class="type-tribe_events post-123879 tribe-clearfix tribe-events-category-go-on-green tribe-events-venue-120337"><div class="tribe-mini-calendar-event event--1 "><div class="list-date"> <span class="list-dayname"> Thu </span> <span class="list-daynumber">02</span></div><div class="list-info"><h2 class="tribe-events-title"> <a href="https://www.redbankgreen.com/event/red-bank-frameworks-vincent-dimattio-2019-10-31/2020-01-02/" rel="bookmark">RED BANK: VINCENT DiMATTIO&#8217;S &#8216;STUDIO SHRINES&#8217;</a></h2><div class="tribe-events-duration"> <span class="tribe-event-date-start">January 2, 10:00 am</span> to <span class="tribe-event-time">5:00 pm</span></div></div></div></div><div class="type-tribe_events post-119339 tribe-clearfix tribe-events-category-go-on-green tribe-events-venue-110279"><div class="tribe-mini-calendar-event event--1 "><div class="list-date"> <span class="list-dayname"> Thu </span> <span class="list-daynumber">02</span></div><div class="list-info"><h2 class="tribe-events-title"> <a href="https://www.redbankgreen.com/event/red-bank-nj-drop-in-storytime-2019-04-23/2020-01-02/" rel="bookmark">RED BANK: DROP-IN STORY TIME FOR KIDS</a></h2><div class="tribe-events-duration"> <span class="tribe-event-date-start">January 2, 1:30 pm</span> to <span class="tribe-event-time">2:30 pm</span></div></div></div></div><div class="type-tribe_events post-115266 tribe-clearfix tribe-events-category-go-on-green tribe-events-venue-112089"><div class="tribe-mini-calendar-event event--1 "><div class="list-date"> <span class="list-dayname"> Thu </span> <span class="list-daynumber">02</span></div><div class="list-info"><h2 class="tribe-events-title"> <a href="https://www.redbankgreen.com/event/middletown-library-language-classes/2020-01-02/" rel="bookmark">MIDDLETOWN: RUSSIAN LANGUAGE FOR ADULTS</a></h2><div class="tribe-events-duration"> <span class="tribe-event-date-start">January 2, 7:00 pm</span> to <span class="tribe-event-time">8:00 pm</span></div></div></div></div><div class="type-tribe_events post-119098 tribe-clearfix tribe-events-category-go-on-green tribe-events-venue-110279"><div class="tribe-mini-calendar-event event--1 "><div class="list-date"> <span class="list-dayname"> Thu </span> <span class="list-daynumber">02</span></div><div class="list-info"><h2 class="tribe-events-title"> <a href="https://www.redbankgreen.com/event/red-bank-nj-artists-workshop-2/2020-01-02/" rel="bookmark">RED BANK: MONTHLY ARTISTS&#8217; WORKSHOP</a></h2><div class="tribe-events-duration"> <span class="tribe-event-date-start">January 2, 7:00 pm</span> to <span class="tribe-event-time">8:30 pm</span></div></div></div></div><div class="type-tribe_events post-124704 tribe-clearfix tribe-events-category-go-on-green tribe-events-venue-112520 tribe-events-organizer-115543"><div class="tribe-mini-calendar-event event--1 "><div class="list-date"> <span class="list-dayname"> Fri </span> <span class="list-daynumber">03</span></div><div class="list-info"><h2 class="tribe-events-title"> <a href="https://www.redbankgreen.com/event/shrewsbury-gait-balance/" rel="bookmark">SHREWSBURY: IMPROVE YOUR GAIT AND BALANCE</a></h2><div class="tribe-events-duration"> <span class="tribe-event-date-start">January 3, 11:00 am</span> to <span class="tribe-event-time">12:00 pm</span></div></div></div></div><p class="tribe-events-widget-link"> <a href="https://www.redbankgreen.com/events/" rel="bookmark"> View More&hellip; </a></p></section><section class="clearfix"><div class="secondary"></div><div class="secondary last"></div></section></aside></div></div><div id="footerwrap"><div class="footer-menu"><ul class="social-list"><li><a target="_blank" href="http://facebook.com/redbankgreen" class="facebook">Facebook</a></li><li><a target="_blank" href="http://twitter.com/redbankgreen" class="twitter">Twitter</a></li><li><a target="_blank" href="http://www.youtube.com/user/redbankgreen" class="youtube">YouTube</a></li><li><a target="_blank" href="http://www.flickr.com/photos/36177195@N07/" class="flickr">Flickr</a></li><li><a target="_blank" href="https://www.redbankgreen.com/feed/rss/" class="rss">RSS</a></li></ul><div class="info-block"><div class="address"> <span class="name">redbankgreen.com</span><p> PO Box 8683 <br/> Red Bank NJ 07701</p></div><div class="footer-nav"><div class="menu-page-menu-top-container"><ul id="menu-page-menu-top" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-83287 home-menu-link"><a href="https://www.redbankgreen.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83269 about-menu-link"><a href="https://www.redbankgreen.com/about-redbankgreen/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83270 advertise-menu-link"><a href="https://www.redbankgreen.com/advertising-on-redbankgreen/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84203 contact-menu-link"><a href="https://www.redbankgreen.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-83272 archive-menu-link"><a href="https://www.redbankgreen.com/archive/">Archive</a></li></ul></div><div class="footer-nav-menu"><ul id="menu-menu-below-masthead-labor-day-launch-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111447 new-calendar-menu-link"><a href="/events">New Calendar</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83297 piehole-menu-link"><a href="https://www.redbankgreen.com/category/piehole/">PieHole</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83298 all-good-menu-link"><a href="https://www.redbankgreen.com/category/all-good/">All Good</a></li></ul></div></div><div style="clear:both;"></div><div class="disclaimer"> &copy; 2020 redbankgreen.com. No portion
of this website or its content can be used without permission.
All rights reserved.</div></div></div><footer id="footer" class="clearfix"><div class="footer-widgets clearfix"><div class="col3-1 first"><div id="bs_zones-26" class="widget bs_zones"><div><broadstreet-zone zone-id="68574" keywords="not_home_page,not_landing_page,is_article_page,fair_haven,featured,government,land-use-zoning,whats-going-on-here,fair-haven-spost-office-gets-new-sign,post" soft-keywords="true"></broadstreet-zone></div></div></div><div class="col3-1 "></div><div class="col3-1 "></div></div><div class="footer-text clearfix"></div></footer></div></div></div> <script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','fair_haven','featured','government','land-use-zoning','whats-going-on-here','fair-haven-spost-office-gets-new-sign','post']</script> <script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["fair_haven","featured","government","land-use-zoning","whats-going-on-here","fair-haven-spost-office-gets-new-sign","post"],"url":"fair-haven-spost-office-gets-new-sign"};</script> <script data-cfasync='false'>window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(2);
 });</script> <style id='simple-share-buttons-adder-ssba-inline-css' type='text/css'>.ssba{-moz-border-radius:10px;-webkit-border-radius:10px;-khtml-border-radius:10px;border-radius:10px;-o-border-radius:10px}.ssba img{width:38px!important;padding:2px;border:0;box-shadow:none!important;display:inline!important;vertical-align:middle;box-sizing:unset}.ssba-classic-2 .ssbp-text{display:none!important}.ssba .fb-save{padding:2px;line-height:33px}.ssba,.ssba a{text-decoration:none;background:none;font-weight:700}#ssba-bar-2 .ssbp-bar-list{max-width:48px!important;}#ssba-bar-2 .ssbp-bar-list li a{height:48px!important;width:48px!important}#ssba-bar-2 .ssbp-bar-list li a::before{line-height:48px!important;;font-size:18px}#ssba-bar-2 .ssbp-bar-list li{margin:0 0!important}@media only screen and (max-width:750px){#ssba-bar-2{display:block}}@font-face{font-family:'ssbp';src:url(https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?xj3ol1);src:url('https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.eot?#iefixxj3ol1') format('embedded-opentype'),url(https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.woff?xj3ol1) format('woff'),url(https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.ttf?xj3ol1) format('truetype'),url('https://www.redbankgreen.com/wp-content/plugins/simple-share-buttons-adder/fonts/ssbp.svg?xj3ol1#ssbp') format('svg');font-weight:400;font-style:normal;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale}</style> <script type='text/javascript'>/* <![CDATA[ */ var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.redbankgreen.com\/checkout\/","is_cart":"","cart_redirect_after_add":"no"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_b1208e299d170bae830f5bc3c367c161","fragment_name":"wc_fragments_b1208e299d170bae830f5bc3c367c161","request_timeout":"5000"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var themifyScript = {"lightbox":{"lightboxSelector":".lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":".post-content a[href$=jpg],.page-content a[href$=jpg],.post-content a[href$=gif],.page-content a[href$=gif],.post-content a[href$=png],.page-content a[href$=png],.post-content a[href$=JPG],.page-content a[href$=JPG],.post-content a[href$=GIF],.page-content a[href$=GIF],.post-content a[href$=PNG],.page-content a[href$=PNG],.post-content a[href$=jpeg],.page-content a[href$=jpeg],.post-content a[href$=JPEG],.page-content a[href$=JPEG]","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":".post, .type-page, .type-highlight, .type-slider","gallerySelector":".gallery-icon > a[href$=jpg],.gallery-icon > a[href$=gif],.gallery-icon > a[href$=png],.gallery-icon > a[href$=JPG],.gallery-icon > a[href$=GIF],.gallery-icon > a[href$=PNG],.gallery-icon > a[href$=jpeg],.gallery-icon > a[href$=JPEG]","lightboxGalleryOn":true},"lightboxContext":"#pagewrap"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var tbLocalScript = {"isTouch":"","animationInviewSelectors":[".fly-in > .post",".fly-in .row_inner > .tb-column",".fade-in > .post",".fade-in .row_inner > .tb-column",".slide-up > .post",".slide-up .row_inner > .tb-column",".col4-1.fly-in",".col4-2.fly-in, .col4-3.fly-in",".col3-1.fly-in",".col3-2.fly-in",".col2-1.fly-in",".col-full.fly-in",".col4-1.fade-in",".col4-2.fade-in",".col4-3.fade-in",".col3-1.fade-in",".col3-2.fade-in",".col2-1.fade-in",".col-full.fade-in",".col4-1.slide-up",".col4-2.slide-up",".col4-3.slide-up",".col3-1.slide-up",".col3-2.slide-up",".col2-1.slide-up",".col-full.slide-up"]}; /* ]]> */</script> <script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script> <div id="fb-root"></div> <script src="https://www.redbankgreen.com/wp-content/cache/min/1/36f9070ff5c4243d2db6d61e5b34d4d2.js" data-minify="1" defer></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1577985941 -->